source: mod_gnutls/debian/patches/0007-Do-not-treat-warnings-about-deprecated-declarations-.patch @ 36663ec

debian/masterdebian/stretch-backports
Last change on this file since 36663ec was 36663ec, checked in by Thomas Klute <thomas2.klute@…>, 4 years ago

Add test suite and compatibility patches from master

Added 0002-Test-suite-Run-flock-with-verbose-to-log-timeouts.patch: test suite fix
Added 0005-Check-if-flock-supports-verbose.patch: test suite fix
Added 0004-Test-suite-Make-timeouts-for-server-locks-and-HTTPS-.patch: test suite fix
Added 0006-Test-suite-Do-not-explicitly-set-the-mutex-type-to-d.patch: test suite fix
Added 0007-Do-not-treat-warnings-about-deprecated-declarations-.patch: GnuTLS 3.5.9 compatibility
Added 0003-Test-suite-Log-if-a-process-to-be-stopped-by-PID-fil.patch: test suite logging

  • Property mode set to 100644
File size: 856 bytes
  • configure.ac

    From: Thomas Klute <thomas2.klute@uni-dortmund.de>
    Date: Sun, 19 Feb 2017 18:57:56 +0100
    Subject: Do not treat warnings about deprecated declarations as errors
    
    GnuTLS has declared OpenPGP support as deprecated in version
    3.5.9. Treating deprecation warnings as errors causes the build to
    fail with this version, so exempt them from "-Werror" until OpenPGP
    support is removed from mod_gnutls.
    ---
     configure.ac | 2 +-
     1 file changed, 1 insertion(+), 1 deletion(-)
    
    diff --git a/configure.ac b/configure.ac
    index cc3e8ae..3335773 100644
    a b AC_ARG_ENABLE(strict, 
    6464
    6565STRICT_CFLAGS=""
    6666if test "$use_strict" != "no"; then
    67         STRICT_CFLAGS="-Wall -Werror -Wextra"
     67        STRICT_CFLAGS="-Wall -Werror -Wextra -Wno-error=deprecated-declarations"
    6868fi
    6969
    7070AC_MSG_CHECKING([whether to enable SRP functionality])
Note: See TracBrowser for help on using the repository browser.