source: mod_gnutls/m4/libgnutls.m4 @ 0e277f2

debian/masterdebian/stretch-backportsjessie-backportsmsvaupstream
Last change on this file since 0e277f2 was abce298, checked in by Nokis Mavrogiannopoulos <nmav@…>, 12 years ago

added new m4 directory

  • Property mode set to 100644
File size: 7.5 KB
Line 
1dnl Autoconf macros for libgnutls-extra
2dnl $id$
3
4# Modified for LIBGNUTLS_EXTRA -- nmav
5# Configure paths for LIBGCRYPT
6# Shamelessly stolen from the one of XDELTA by Owen Taylor
7# Werner Koch   99-12-09
8
9dnl AM_PATH_LIBGNUTLS_EXTRA([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
10dnl Test for libgnutls-extra, and define LIBGNUTLS_EXTRA_CFLAGS and LIBGNUTLS_EXTRA_LIBS
11dnl
12AC_DEFUN([AM_PATH_LIBGNUTLS_EXTRA],
13[dnl
14dnl Get the cflags and libraries from the libgnutls-extra-config script
15dnl
16AC_ARG_WITH(libgnutls-extra-prefix,
17          [  --with-libgnutls-extra-prefix=PFX   Prefix where libgnutls-extra is installed (optional)],
18          libgnutls_extra_config_prefix="$withval", libgnutls_extra_config_prefix="")
19
20  if test x$libgnutls_extra_config_prefix != x ; then
21     if test x${LIBGNUTLS_EXTRA_CONFIG+set} != xset ; then
22        LIBGNUTLS_EXTRA_CONFIG=$libgnutls_extra_config_prefix/bin/libgnutls-extra-config
23     fi
24  fi
25
26  AC_PATH_PROG(LIBGNUTLS_EXTRA_CONFIG, libgnutls-extra-config, no)
27  min_libgnutls_version=ifelse([$1], ,0.1.0,$1)
28  AC_MSG_CHECKING(for libgnutls - version >= $min_libgnutls_version)
29  no_libgnutls=""
30  if test "$LIBGNUTLS_EXTRA_CONFIG" = "no" ; then
31    no_libgnutls=yes
32  else
33    LIBGNUTLS_EXTRA_CFLAGS=`$LIBGNUTLS_EXTRA_CONFIG $libgnutls_extra_config_args --cflags`
34    LIBGNUTLS_EXTRA_LIBS=`$LIBGNUTLS_EXTRA_CONFIG $libgnutls_extra_config_args --libs`
35    libgnutls_extra_config_version=`$LIBGNUTLS_EXTRA_CONFIG $libgnutls_extra_config_args --version`
36
37
38      ac_save_CFLAGS="$CFLAGS"
39      ac_save_LIBS="$LIBS"
40      CFLAGS="$CFLAGS $LIBGNUTLS_EXTRA_CFLAGS"
41      LIBS="$LIBS $LIBGNUTLS_EXTRA_LIBS"
42dnl
43dnl Now check if the installed libgnutls is sufficiently new. Also sanity
44dnl checks the results of libgnutls-extra-config to some extent
45dnl
46      rm -f conf.libgnutlstest
47      AC_TRY_RUN([
48#include <stdio.h>
49#include <stdlib.h>
50#include <string.h>
51#include <gnutls/extra.h>
52
53int
54main ()
55{
56    system ("touch conf.libgnutlstest");
57
58    if( strcmp( gnutls_extra_check_version(NULL), "$libgnutls_extra_config_version" ) )
59    {
60      printf("\n*** 'libgnutls-extra-config --version' returned %s, but LIBGNUTLS_EXTRA (%s)\n",
61             "$libgnutls_extra_config_version", gnutls_extra_check_version(NULL) );
62      printf("*** was found! If libgnutls-extra-config was correct, then it is best\n");
63      printf("*** to remove the old version of LIBGNUTLS_EXTRA. You may also be able to fix the error\n");
64      printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
65      printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
66      printf("*** required on your system.\n");
67      printf("*** If libgnutls-extra-config was wrong, set the environment variable LIBGNUTLS_EXTRA_CONFIG\n");
68      printf("*** to point to the correct copy of libgnutls-extra-config, and remove the file config.cache\n");
69      printf("*** before re-running configure\n");
70    }
71    else if ( strcmp(gnutls_extra_check_version(NULL), LIBGNUTLS_EXTRA_VERSION ) )
72    {
73      printf("\n*** LIBGNUTLS_EXTRA header file (version %s) does not match\n", LIBGNUTLS_EXTRA_VERSION);
74      printf("*** library (version %s). This is may be due to a different version of gnutls\n", gnutls_extra_check_version(NULL) );
75      printf("*** and gnutls-extra.\n");
76    }
77    else
78    {
79      if ( gnutls_extra_check_version( "$min_libgnutls_version" ) )
80      {
81        return 0;
82      }
83     else
84      {
85        printf("no\n*** An old version of LIBGNUTLS_EXTRA (%s) was found.\n",
86                gnutls_extra_check_version(NULL) );
87        printf("*** You need a version of LIBGNUTLS_EXTRA newer than %s. The latest version of\n",
88               "$min_libgnutls_version" );
89        printf("*** LIBGNUTLS_EXTRA is always available from ftp://gnutls.hellug.gr/pub/gnutls.\n");
90        printf("*** \n");
91        printf("*** If you have already installed a sufficiently new version, this error\n");
92        printf("*** probably means that the wrong copy of the libgnutls-extra-config shell script is\n");
93        printf("*** being found. The easiest way to fix this is to remove the old version\n");
94        printf("*** of LIBGNUTLS_EXTRA, but you can also set the LIBGNUTLS_EXTRA_CONFIG environment to point to the\n");
95        printf("*** correct copy of libgnutls-extra-config. (In this case, you will have to\n");
96        printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
97        printf("*** so that the correct libraries are found at run-time))\n");
98      }
99    }
100  return 1;
101}
102],, no_libgnutls=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
103       CFLAGS="$ac_save_CFLAGS"
104       LIBS="$ac_save_LIBS"
105  fi
106
107  if test "x$no_libgnutls" = x ; then
108     AC_MSG_RESULT(yes)
109     ifelse([$2], , :, [$2])
110  else
111     if test -f conf.libgnutlstest ; then
112        :
113     else
114        AC_MSG_RESULT(no)
115     fi
116     if test "$LIBGNUTLS_EXTRA_CONFIG" = "no" ; then
117       echo "*** The libgnutls-extra-config script installed by LIBGNUTLS_EXTRA could not be found"
118       echo "*** If LIBGNUTLS_EXTRA was installed in PREFIX, make sure PREFIX/bin is in"
119       echo "*** your path, or set the LIBGNUTLS_EXTRA_CONFIG environment variable to the"
120       echo "*** full path to libgnutls-extra-config."
121     else
122       if test -f conf.libgnutlstest ; then
123        :
124       else
125          echo "*** Could not run libgnutls test program, checking why..."
126          CFLAGS="$CFLAGS $LIBGNUTLS_EXTRA_CFLAGS"
127          LIBS="$LIBS $LIBGNUTLS_EXTRA_LIBS"
128          AC_TRY_LINK([
129#include <stdio.h>
130#include <stdlib.h>
131#include <string.h>
132#include <gnutls/extra.h>
133],      [ return !!gnutls_extra_check_version(NULL); ],
134        [ echo "*** The test program compiled, but did not run. This usually means"
135          echo "*** that the run-time linker is not finding LIBGNUTLS_EXTRA or finding the wrong"
136          echo "*** version of LIBGNUTLS_EXTRA. If it is not finding LIBGNUTLS_EXTRA, you'll need to set your"
137          echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
138          echo "*** to the installed location  Also, make sure you have run ldconfig if that"
139          echo "*** is required on your system"
140          echo "***"
141          echo "*** If you have an old version installed, it is best to remove it, although"
142          echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"
143          echo "***" ],
144        [ echo "*** The test program failed to compile or link. See the file config.log for the"
145          echo "*** exact error that occured. This usually means LIBGNUTLS_EXTRA was incorrectly installed"
146          echo "*** or that you have moved LIBGNUTLS_EXTRA since it was installed. In the latter case, you"
147          echo "*** may want to edit the libgnutls-extra-config script: $LIBGNUTLS_EXTRA_CONFIG" ])
148          CFLAGS="$ac_save_CFLAGS"
149          LIBS="$ac_save_LIBS"
150       fi
151     fi
152     LIBGNUTLS_EXTRA_CFLAGS=""
153     LIBGNUTLS_EXTRA_LIBS=""
154     ifelse([$3], , :, [$3])
155  fi
156  rm -f conf.libgnutlstest
157  AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS)
158  AC_SUBST(LIBGNUTLS_EXTRA_LIBS)
159
160  LIBGNUTLS_LIBS=$LIBGNUTLS_EXTRA_LIBS
161  LIBGNUTLS_CFLAGS=$LIBGNUTLS_EXTRA_CFLAGS
162  LIBGNUTLS_VERSION=`$LIBGNUTLS_EXTRA_CONFIG $libgnutls_extra_config_args --version`
163  LIBGNUTLS_PREFIX="`$LIBGNUTLS_EXTRA_CONFIG $libgnutls_extra_config_args --prefix`"
164  GNUTLS_CERTTOOL="${LIBGNUTLS_PREFIX}/bin/certtool"
165
166  AC_SUBST(LIBGNUTLS_CFLAGS)
167  AC_SUBST(LIBGNUTLS_LIBS)
168  AC_SUBST(LIBGNUTLS_VERSION)
169  AC_SUBST(LIBGNUTLS_PREFIX)
170  AC_SUBST(LIBGNUTLS_CERTTOOL)
171 
172])
173
174dnl *-*wedit:notab*-*  Please keep this as the last line.
Note: See TracBrowser for help on using the repository browser.