Changeset 0f52d48 in mod_gnutls for test/test-28_HTTP2_support.bash


Ignore:
Timestamp:
Jan 8, 2020, 5:06:31 PM (10 months ago)
Author:
Fiona Klute <fiona.klute@…>
Branches:
master, proxy-ticket
Children:
482bafc
Parents:
baa0056
Message:

Switch most tests to hooks.py instead of preconditions in test scripts

The new function mgstest.require_apache_modules() covers required
Apache modules, the rest is individual stuff.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • test/test-28_HTTP2_support.bash

    rbaa0056 r0f52d48  
    11#!/bin/bash
    2 #
    3 # Check if HTTP/2 connections using mod_gnutls and mod_http2 work
    4 
    5 set -e
    6 
    7 if [ ! -r ${AP_LIBEXECDIR}/mod_http2.so ]; then
    8     echo "mod_http2.so not found, skipping." 2>&1
    9     exit 77
    10 elif [ "$(basename ${HTTP_CLI})" != "curl" ] \
    11        || ! ${HTTP_CLI} -V | grep -P '\sHTTP2($|\s)'; then
    12     echo "Curl not found or does not support HTTP/2, skipping." 2>&1
    13     exit 77
    14 fi
    15 
    162. ${srcdir}/netns_py.bash ${srcdir}/runtest.py --test-number 28
Note: See TracChangeset for help on using the changeset viewer.