Changeset 16068f4 in mod_gnutls for configure.ac


Ignore:
Timestamp:
Sep 26, 2004, 11:21:40 PM (15 years ago)
Author:
Paul Querna <chip@…>
Branches:
debian/master, debian/stretch-backports, jessie-backports, master, msva, upstream
Children:
6a8a839
Parents:
9706fc2
Message:

libgnutls support

File:
1 edited

Legend:

Unmodified
Added
Removed
  • configure.ac

    r9706fc2 r16068f4  
    1414
    1515
    16 AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
    17 if test "x$PKG_CONFIG" = "xno"; then
    18         AC_MSG_ERROR([You need to install pkg-config])
    19 fi
    20 
    21 PKG_PATH=
    22 
    2316AP_VERSION=2.0.40
    2417CHECK_APACHE(,$AP_VERSION,
     
    2720)
    2821
    29 MODULE_CFLAGS="${APXS_CFLAGS} ${AP_INCLUDES} ${APR_INCLUDES} ${APU_INCLUDES}"
     22MIN_TLS_VERSION=1.1.0
     23CHECK_LIBGNUTLS($MIN_TLS_VERSION)
     24
     25MODULE_CFLAGS="${LIBGNUTLS_CFLAGS} ${APXS_CFLAGS} ${AP_INCLUDES} ${APR_INCLUDES} ${APU_INCLUDES}"
     26MODULE_LIBS="${LIBGNUTLS_LIBS}"
    3027
    3128AC_SUBST(MODULE_CFLAGS)
     29AC_SUBST(MODULE_LIBS)
    3230
    3331AC_CONFIG_FILES([Makefile src/Makefile])
     
    3735echo "Configuration summary for mod_gnutls"
    3836echo ""
    39 echo "   * Apache modules directory = ${AP_LIBEXECDIR}"
     37echo "   * Apache Modules directory:    ${AP_LIBEXECDIR}"
     38echo "   * GnuTLS Library Version:      ${LIBGNUTLS_VERSION}"
    4039echo ""
    4140echo "---"
Note: See TracChangeset for help on using the changeset viewer.