Changeset 25e6b32 in mod_gnutls for include/mod_gnutls.h.in


Ignore:
Timestamp:
Jan 29, 2013, 8:05:42 PM (7 years ago)
Author:
Daniel Kahn Gillmor <dkg@…>
Branches:
debian/master, debian/stretch-backports, jessie-backports, master, msva, upstream
Children:
adb7135
Parents:
c0dd3ab
git-author:
Daniel Kahn Gillmor <dkg@…> (01/29/13 16:06:49)
git-committer:
Daniel Kahn Gillmor <dkg@…> (01/29/13 20:05:42)
Message:

remove obsolete mgs_handle_t.rsa_params -- RSA-EXPORT is not supported

This change breaks backward compatibility if anyone is trying to link
some other code to mod_gnutls. I don't think that's happening right
now, so I am willing to break backward compatibility to have a cleaner
codebase going forward.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • include/mod_gnutls.h.in

    rc0dd3ab r25e6b32  
    121121        /* GnuTLS Priorities */
    122122    gnutls_priority_t priorities;
    123         /* GnuTLS RSA Parameters [Obselete] */
    124     gnutls_rsa_params_t rsa_params;
    125123        /* GnuTLS DH Parameters */
    126124    gnutls_dh_params_t dh_params;
Note: See TracChangeset for help on using the changeset viewer.