Changeset 6870585 in mod_gnutls for t


Ignore:
Timestamp:
Nov 15, 2013, 9:50:29 PM (6 years ago)
Author:
Daniel Kahn Gillmor <dkg@…>
Branches:
debian/master, debian/stretch-backports, jessie-backports, master, upstream
Children:
fa45dcb
Parents:
925318f
Message:

Do not request X.509 certs when we are expecting OpenPGP

Apparently libgnutls26 on the server side does not deal properly with
the situation where it only has an OpenPGP certificate, and the client
sends an RFC 6091 extension that indicates (X509,OpenPGP) in that
order. This may not be necessary if we link against libgnutls28.

It's OK to revert this if it works against libgnutls28, and we decide
to make mod_gnutls depend on libgnutls28 instead of libgnutls26.

File:
1 edited

Legend:

Unmodified
Added
Removed
Note: See TracChangeset for help on using the changeset viewer.