Changeset bfef00c in mod_gnutls


Ignore:
Timestamp:
Feb 2, 2020, 7:19:25 AM (5 months ago)
Author:
Fiona Klute <fiona.klute@…>
Branches:
master, proxy-ticket
Children:
c4a6889
Parents:
1a6eeae
Message:

Show the right GnuTLS version when using ./configure --with-gnutls-dev

Previously the version information was always loaded from the
system-wide installation, now the pkg-config file from the GnuTLS git
tree is used if enabled.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • configure.ac

    r1a6eeae rbfef00c  
    3030    AC_MSG_ERROR([*** Apache version $AP_VERSION not found!])
    3131)
     32
     33PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 3.6.3])
     34LIBGNUTLS_VERSION=`pkg-config --modversion gnutls`
    3235
    3336dnl Maybe use the binaries for tests, too?
     
    4245                        LIBGNUTLS_CFLAGS="-I${with_gnutls_dev}/lib/includes"
    4346                        LIBGNUTLS_LIBS="-lgnutls -L${with_gnutls_dev}/lib/.libs -R${with_gnutls_dev}/lib/.libs"
     47                        LIBGNUTLS_VERSION=`PKG_CONFIG_PATH="${with_gnutls_dev}/lib" pkg-config --modversion gnutls`
    4448                ],
    4549                [AC_MSG_ERROR([--with-gnutls-dev=DIR requires a directory!])])
    4650        ], [])
    47 
    48 PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 3.6.3])
    49 
    50 LIBGNUTLS_VERSION=`pkg-config --modversion gnutls`
    5151
    5252AC_ARG_ENABLE(vpath-install,
Note: See TracChangeset for help on using the changeset viewer.