Ignore:
Timestamp:
Sep 28, 2018, 11:22:30 AM (17 months ago)
Author:
Fiona Klute <fiona.klute@…>
Branches:
debian/master, master
Children:
eb4cab7
Parents:
72b669e
Message:

Test suite: Use ciphers, not protocol versions for priority mismatch test

This works around a bug in GnuTLS 3.6.4 (gnutls_priority_set in post
client hello function breaks handshake for clients with TLS versions
before TLS 1.3), see https://gitlab.com/gnutls/gnutls/issues/580

File:
1 edited

Legend:

Unmodified
Added
Removed
  • test/tests/23_TLS_reverse_proxy_mismatched_priorities/apache.conf

    r72b669e rc33ef88  
    1313 GnuTLSProxyEngine      On
    1414 GnuTLSProxyCAFile      authority/x509.pem
    15  GnuTLSProxyPriorities  NORMAL:-VERS-TLS-ALL:+VERS-TLS1.2
     15 GnuTLSProxyPriorities  NORMAL:-CIPHER-ALL:+AES-256-GCM
    1616 ProxyPass /proxy/ https://${BACKEND_HOST}:${BACKEND_PORT}/
    1717 ProxyPassReverse /proxy/ https://${BACKEND_HOST}:${BACKEND_PORT}/
Note: See TracChangeset for help on using the changeset viewer.