Changeset ef06c74 in mod_gnutls for src/gnutls_io.c

Timestamp:
Jun 18, 2016, 3:18:36 PM (4 years ago)
Author:
Thomas Klute <thomas2.klute@…>
Branches:
debian/master, debian/stretch-backports, master, proxy-ticket, upstream
Children:
f1147b6
Parents:
ac3f500
Message:

Compatibility code for GCC version < 5

The builtin_add_overflow() which is used for safe integer type
conversion was introduced with GCC 5, and thus unfortunately is not
available in Debian stable.

The "!defined(clang)" part in the version check is because Clang
3.8 has the builtin, but pretends to be GCC 4 as far as the GNUC
macro is concerned.

(No files)

Note: See TracChangeset for help on using the changeset viewer.