Opened 3 years ago

Closed 23 months ago

#98 closed defect (fixed)

TLS does not start if the source and destination IP addresses are the same

Reported by: stéphane bortzmeyer Owned by: https://id.mayfirst.org/dkg
Priority: critical Component: code
Version: Keywords:
Cc:

Description

The problem have been reported in Debian https://bugs.debian.org/642357 but apparently ignored. I can confirm it still exists for Debian "jessie", GnuTLS 3.3.8 and mod-gnutls 0.5.10.

Change History (1)

comment:1 Changed 23 months ago by thomas klute

  • Resolution set to fixed
  • Status changed from new to closed

The test suite included since 0.6 uses connections to localhost exclusively in the default configuration, so I'm convinced that Daniel's comment on the Debian bug is correct and the bug has been fixed.

Note: See TracTickets for help on using tickets.